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Swordfish Version 1.8.2 1 OVERVIEW

1 Overview

The Swordfish software has been developed to operate in conjunction with any of 4Deep’s suite of holo-
graphic microscopes (Desktop, Cuvette, Submersible [Standard 500m, 2000m and 2000m+], Autonomous).

This user guide is strictly related to the installation, use and functionality of the Swordfish software. For a
detailed description of the setup and operation of your 4Deep microscope, please refer to the respective
user guide.

The main functions of Swordfish are: to collect holograms (with a 4Deep microscope) and complete sizing
analysis on groups of holograms. For viewing reconstructed holograms, and basis analysis, see 4Deep’s
software package Octopus. For object classification, see 4Deep’s software package Stingray.

For example, Swordfish can be used for example in

• Detect and measure microorganisms such as algae or zooplankton within the water column.

• Detect particular matter and floc.

• Detect oil and gas bubbles.

• Detect particles in the industrial solutions, in food or pharmaceutical applications.

1.1 Purpose

Swordfish operates by means of recording images from the camera at the rate of up to 16 frames per
second, reconstructing them and then detecting and counting particles within the volume of water. The
software automatically counts, images and analyzes particles in the water from 1 micron to 2 millimeters in
size. The particle size distributions can be obtained for the measured particle populations.

The measurement technique used is digital inline holographic microscopy in transmission. The objects in
the holograms, imaged by the microscope, are between 1 um and 2 mm in size.

1.2 Benefits

Compared to a traditional microscope, the holographic microscope, and the Swordfish software have many
benefits:

• Instant: live imaging of samples without any manipulation.

• Eliminate tasks: capable to count and measure particles automatically in 2D and 3D.

• Faster: image-based rapid particle detection up to 16 frames per second

• Larger sample volume: detect more particles than with traditional microscopy

• More control: advanced particle detection criteria, including size, intensity, threshold and shape (round
& non-round)

• Better remediation: exclusively detect oil droplets and gas bubbles in water

• Versatile: open data formats allowing exchange of information

• Sample rate choices: produce particle size distributions at sample rates from 1 second to 1 hour.
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2 INSTALLATION Swordfish Version 1.8.2

2 Installation

2.1 Compatibility

The current version of Swordfish (1.8.0) is compatible to run on Microsoft Windows XP SP3 or newer.

The hologram reconstruction rate of Swordfish is up to 16 fps (2048 x 2048 pixels hologram). The particle
data can be saved to a NetCDF-4 format. Analysis results are exported to MS Excel and CSV formats.

2.2 Installation Package

To install Swordfish software on your computer

• Download the software from our website: http://4-deep.com/software-downloads/.

• Insert the HASP key supplied; Follow the onscreen instructions.

• Note that for fast hologram reconstructions, 4Deep software requires a CUDA-enabled NVIDIA graph-
ics card to be installed in the computer. For the list of CUDA-enabled graphics chips, refer to https:
//developer.nvidia.com/cuda-gpus.

• If your NVIDIA drivers are not up to date, please update them at http://www.nvidia.com/Download/
index.aspx.

• Install Swordfish by running SwordfishInstaller.exe and following the onscreen instructions. Selecting
the default parameters should typically be acceptable for most installations.

Figure 1: Swordfish installer, selection of the installation folder

2.3 Connection of the HASP dongle and starting Swordfish

After installation, attach the supplied HASP hardware protection key (dongle) to a computer USB port.
Make sure the dongle light turns on. Launch Swordfish by going into Windows Start Menu-> 4Deep->
Swordfish. The Swordfish software will start and will automatically attempt to connect to the camera.
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Swordfish Version 1.8.2 3 SYSTEM OVERVIEW

Figure 2: Swordfish software after launch

When started for the first time, Swordfish offers to select the instrument profile, or create a new one. Select
the instrument profile that corresponds to the instrument being used as the instruments have different laser
to camera distances and pixel sizes. Note that this dialog will only open the first time Swordfish is opened,
so if you need to change these settings later they are found under Count -> Count Options (see Subsection
4.1 for more details).

Figure 3: Initial set-up of Swordfish based on the microscope used

3 System Overview

This User Guide details the functionality and use of Swordfish from a workflow perspective. In general, the
workflow of Swordfish follows four broad categories:

• Capture/Record/Collect Holograms (Section 4)

• Object size analysis from Holograms (Section 5)

• Saving/exporting Holograms and data (Section 6)

3



3 SYSTEM OVERVIEW Swordfish Version 1.8.2

For ease of use, the details of each Section listed above will be guided with Figures of both the Main Menu
(Figure 4). The following sections briefly introduce the Home Screen of Swordfish to give users a quick
overview of its layout.

3.1 Main Menu

Most of the Settings and functionality of Swordfish is located in the Main Menu (see Figure 4). The following
gives a brief explanation of each option in the Main Menu (for more details regarding these options, see the
Sections referenced).

Figure 4: Main menu, showing the options under each heading

3.1.1 File

Select Project - selects the project file. Either select a new project file, or existing project file. In case the
existing project is selected, the data will be appended to the file. Existing project files can be dragged to the
Swordfish window and dropped in for loading.

Analyze Offline Holograms – allows for the counting of particles in previously collected holograms. Select
the holograms to be analyzed from the directory, more than one at a time must be selected.

Export Current Histogram - exports current histogram and analysis data to Excel spreadsheet or CSV text
file. Data for the currently selected row in the data summary table will be exported.

Export All Histograms - exports all the histograms and analysis data to Excel spreadsheet or CSV text
file. Note that Excel spreadsheets are limited to 255 sheets, and therefore only 255 rows of data can be
exported. There is no limitation when exporting data in CSV format.

Export Time Plot – exports the statistical data in rows of time steps to an Excel spreadsheet or CSV text
file.

Export Cross-plot - exports the selected variables to an Excel spreadsheet or a CSV text file.

Quit - closes the Swordfish software.

3.1.2 Count

Start Counting - begins the counting process. Data will be appended to the current project file.

Stop Counting - stops the counting process.

Select Backgound Count - begins automated subtraction of selected count particle data from the current
statistics. Refer to Section 4.4 Noise Reduction for more information.

Clear Background Count - returns Swordfish to normal statistics out put.

Count Options - opens the Count Options dialog.

4
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3.1.3 Help

About - shows information about the software.

User Guide - opens software User Guide.

Check for updates - Swordfish will check for updates when prompted.

4 Collecting the Holograms

If you are analyzing already collected holograms, you should go directly to Section 5.

To collect holograms, it is important to setup both the microscope and Swordfish properly. The steps below
detail how to setup and use Swordfish in conjunction with a 4Deep microscope. Note that you should be
using both this user guide, as well as the user guide for your microscope for complete setup. You will also
notice that much of the information listed below is also listed in the Desktop/Submersible User Guide.

4.1 Acquisition setup for Swordfish and the microscope

• Set up the microscope and turn it on. Please see the User Guide for the instrument you are using for
setup, installation and use before continuing.

• Start Swordfish and click on the Camera Tab (right panel in Swordfish) to connect to the camera.

– If the camera is connected, but you see a black image in the Camera View, wait 2 min for the
camera auto exposure to find the correct exposure values for the current light intensity.

Figure 5: An example image from the camera during Swordfish operation

– If after 2 minutes the Camera View is still black, make sure that the laser is properly connected
and powered on.

– If camera is not connected, check that the camera cables are properly attached, and power is on.
Click Connect to Camera button to retry the connection. Note: it may take several seconds to
connect to the camera. For more help on connecting the camera, see the Troubleshooting Guide
(Section 7).

5



4 COLLECTING THE HOLOGRAMS Swordfish Version 1.8.2

– The live view from the camera appear in the preview and hologram reconstructions will be per-
formed in real time at the rate of up to 16 frames per second. Higher frame rates are possible
with reduced image sizes (ex: 50 fps for 1024x1024 pixels). All reconstruction parameters can
be applied to the real time reconstructions, including the reconstruction position and mode.

Figure 6: Camera view (top) and the camera options (bottom)

• To properly reconstruct holograms, settings need to be setup correctly in Swordfish.

– The Count Options (under Count in the Main Menu) include:

* Camera pixel size - pixel size of the camera (in µm).

* Laser to camera distance - distance (in mm) between the point source and the camera
sensor.

* Laser wavelength - wavelength of the laser light source (in nm).

* Presets: Presets are used for storing and quick recall of the optical path configurations.
These can be used to store the optical configurations of the custom holographic setups, or
experimental conditions. The 4 standard presets: Desktop, Submersible, Submersible
2000 and Cuvette correspond to the optimal configuration of the respective 4Deep micro-
scopes.

The standard presets cannot be deleted, and any modifications to these presets will not
be stored – the default values will be restored upon the preset switch.

– For the Desktop, select the Preset Option for the Desktop: Count-> Count Options-> Optical
Path ->Preset (see Main Menu Figure 4 for location). To create a custom preset, press the Add
preset(+) button, and give the new preset a name. Any modifications to the preset will be
stored when OK button is pressed. To delete a custom preset, press the Remove preset (-)
button. The pixel size and laser wavelength settings should not need to be changed unless you
are using a third-party microscope.

– For other 4Deep microscopes, select the Preset Option for whichever microscope you are using:
Settings -> Reconstruction Options-> Optical Path-> Preset.

– For third-party microscopes, create a custom preset by pressing the Add preset(+) button,
and give the new preset a name. Any modifications to the preset will be stored when OK button is
pressed. To delete a custom preset, press the Remove preset (-) button.

6
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Figure 7: Select instrument preset dialog

The user can also select the plane within the reconstruction (the distance from the point source to the object
within the volume) to perform counting analysis in that specific plane, using the Reconstruction plane slider,
or by clicking the “Select Reconstruction Plane Automatically” option.

5 Counting and Analysis

The control of the counting and recording processes are the main function of the Swordfish user interface.
The general workflow of analysis in Swordfish is:

1. Setup a Project (Subsection 5.1)

2. Setup the Parameters for Counting (Subsection 5.2)

3. Counting and Analysis (Subsection 5.3)

At this point, the microscope should be set up, with the camera connected, and the Optical Path set depend-
ing on the instrument being used.

5.1 Setup a Project

To begin analysis, the user will need to create a new project or append to a current project.

• Go to File->Select Project... . If you need to create a new project, type in a project name.
If you are appending to an already created project, locate it in your file directory and select. With
a project file selected, the program will accumulate data to the file; if an existing project is selected,
Swordfish will append data to the current file. In addition, the user may choose to save raw hologram
images in addition to the particle count data. To save raw holograms, go to Settings -> Count Options.

7
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Figure 8: Example of the Swordfish interface during operation

Before the user begins a new project, s/he should know whether s/he plans on counting particles from
already collected holograms (Offline holograms) or counting in real time (with the option to save the raw
holograms).

• If you are analyzing offline holograms, go to File->Analyze Offline Holograms and select the
raw hologram files you wish to analyze.

• If you are analyzing online holograms (ie counting in real-time), you also gave the option to record the
raw holograms.

– To save the raw holographic images turn the option Save raw holograms in addition to
particle data on (Count -> Count Options). The images (in BMP format) will be saved
into the same directory where project file is located, with the project name assigned as a prefix to
the time stamp on the hologram files.

Please note that a high capture rate even over a short period of time will take up much storage
space on the computer. For example, sampling at a rate of 16 fps for 5 minutes will result in 19.2 GB of data
(the size of one frame is 4MB). Please ensure your computer has the space requirements you need before
you begin recording so as to not lose important data.

5.2 Parameters & Presets

Now that the camera and project are setup, the user will need to define and set Parameters for counting.
The counting parameters will largely depend on the type of particle the user is counting. For example, if the
user is testing the effectiveness of dispersants used in oil spills, the user will want to set a size range for the
oil droplets, and/or use the preset for “Dispersed oil, spills”.

5.2.1 Presets

There are four presets which control the counting parameters for common uses. These allow for the quick
selection of the number of parameters designed for a specific application. Selecting a preset sets all the
parameters (sample interval, particle size, threshold, round object detection) to the optimal values for the
specific application. The user can manipulate the parameters to the specifics of the project. The custom
preset is designed for the user-entered parameters and is automatically saved when the program is closed.

8
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Figure 9: Preset selector

Oil & gas exploration - For the discovery of microscopic oil and gas bubbles in the water; an indicator that
under water reserves may be in the vicinity. Sample interval: 10 s, Particle sizes: 60-500 µm, round object
detection is on.

Dispersed oil, spills - For the detection and counting of the smaller droplets typical of dispersed oil. Sample
interval: 10 s, Particle sizes: 5-60 µm, round object detection is on.

Harmful algae - For the detection and counting of potentially toxic algae. Currently the preset is designated
for Alexandrium sp. and similar. Sample interval: 600 s, Particle sizes: 2-40 µm, round object detection is
on.

Floc water contaminants - For the counting and volume fraction analysis of coagulated water contaminants
in municipal systems. Sample interval: 120 s, Particle sizes: 50-500 µm, round object detection is off.

Custom - Parameters are manually set by user. The parameters set by user are remembered when Sword-
fish is closed and recalled on the next launch.

If the user is unsure of the conditions necessary for counting (ie exploratory analysis or unknown size range),
it is strongly recommended that the user record their holograms in Octopus first. Then using the 2D Object
Detection option in Octopus, the user can find optimal parameters for his/her analysis. Please see the
Octopus User Guide for more options.

5.2.2 Parameters

If the presets listed above are not applicable, or the user would like to define his/her own parameters, s/he
can easily do so.

First, the Sample Interval for analyze will need to be set. The Sample Interval determines the amount of
time that has passed between two datasets. For example, if the Sample Interval is 10s, and the user records
for 60s, there would be 6 data points in the dataset. Ultimately, this will determine the number of holograms
in each data set, and hence determine the statistics of the data set. In the Main Window, the statistics for
each sample period are shown. The data from each of these sample interval will represent a datum point in
the other two tabs in the Main Window: Time Plot and Cross Plot.

Figure 10: Swordfish particle detection parameters

9
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Sample interval - The selection of a time frame in which the counting takes place (from 1 s to 1 h). Longer
intervals give more counts, and a better particle size distribution. This setting will also determine the rate at
which the histogram data is updated.

Particle size - Select the maximum and minimum size you wish Swordfish to count within the volume (from
1 to 2000 micrometers).

Threshold - The minimum intensity, or pixel value, to be considered for counting (from 0 to 255). A high
threshold prevents Swordfish from counting out of focus and nondescript particles. A lower threshold can be
used to count objects with high translucency. Auto threshold uses Otsu algorithm to set optimal threshold
for particle detection automatically.

Detect round objects - If only round objects are of interest, selecting this will make Swordfish count only
round objects within the volume.

To optimize the counting parameters, it is highly recommended that the user record raw holograms in Oc-
topus first and use the 2D Object Detection to find the minimum size, maximum size and the intensity
Threshold for the particular object the user is interested in. Please see the 2D Object Detection example in
the Octopus User Guide for more details.

5.2.3 Pulsed Laser Control

Activate laser pulse control - The submersible microscopes from 4Deep have the ability to pulse the
laser, which is controlled by the user when the option is selected. The laser will then pulse once during
the exposure of the camera; in this configuration, exposure control does not change the captured hologram,
only the gain and pulse duration settings will control the intensity of the hologram.

Pulsed laser control is important when the user needs to capture holograms of fast moving objects, or use
the submersible microscope in flowing water conditions or towing.

Pulse duration - User control over the length of the pulse generated. Pulse durations above 6 microseconds
tend to give overexposed holograms from the camera. Use a pulse duration as short as possible while still
illuminating the sample; inspect the holograms from the camera feed for pixel over/under saturation; the
histogram can be used as an additional visual indicator of exposure. Auto pulse control sets the optimal
laser pulse duration/camera gain based on camera image histogram.

5.3 Counting Holograms and Analysis

At this point, all conditions to begin counting are set. Swordfish is ready to start counting.

• Press the “Start counting” button to initiate the particle detection and counting (also under Count
-> Start counting).

• Press the “Stop counting” button to stop the particle detection and counting (also under Count ->
Stop counting).

The particle size or volume distributions are displayed in a histogram format, and update at the user-selected
sample interval. To select whether to calculate the histogram and statistics data based on particle size, select
By size in the drop down box. To calculate histogram and statistics based on particle volume (assuming
spherical particles), select By volume option. The scaling of the histogram axes occurs automatically for
each sample interval, based on maximum particle size. The length of the sample interval determines the
statistical accuracy of the particle size or volume distribution histogram.

By selecting the D[4,3] option, relative particle volume as a fraction of total volume of all particles (the
volume in each bin divided by the total volume of all of the particles) is calculated in each histogram bin.
Thus the user can identify which volume bin dominates the total volume.

10
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Figure 11: Particle size distribution histogram

The cumulative distribution plot (blue line) represents the cumulative particle distribution, where the total
number of particles in all bins is equal to 100%, and number of particles in each bin is calculated as a
percentage.

Figure 12: Particle statistics time plot

The time plots display the changes of the variable selected from the drop down menu on the right, over time.
The data in the time plot is updated after each data append at the end of the sampling interval. The time
plot data can be exported in MS Excel and .csv formats.

Figure 13: Particle statistics cross plot
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The cross plots display the selected statistics to plot in an X-Y graph. The drop down menu in top left hand
corner allows for the selection of the X variable, and the upper right one selects the Y variable. The data
in the cross plot is updated after each data append at the end of the sampling interval. The cross plot data
can be exported in MS Excel and .csv formats.

Figure 14: Data summary table

The data summary table displays the previous count data sets from the selected project file. The data
displayed on each line corresponds to a single sample interval, and includes the date and time when the
data was recorded, the calculated volume fraction, concentration, the measured minimum and maximum
particle sizes or volumes, the calculated mean particle size or volume, median, mode, D10 and D90 of the
histogram, the standard deviation, and the tallied count for the sample interval.

Increasing the sample interval will average larger amounts of data to give more accurate figures within
the data summaries. The particle concentration within the volume is calculated in parts per million (ppm)
taking into the account the depth of field of the imaging plane being reconstructed and background frame
subtraction.

By switching the view from Camera view to Detected view, the user can then adjust parameters such
that optimal object detection and counting takes place for the current conditions.

Figure 15: Detected particle view with detected particles highlighted

5.4 Use of a Background

In the instance of using Swordfish in conditions where the signal from the microscope has many particles
which are not of interest to count. Swordfish can deal with this by subtracting selected data from the current
out put with Select Background Count.

Record some data from the current conditions, from a sample not contaning particles of interest, and click on
a out put count which well represents the background data. Select Count/Select Background Count

12
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to subtract the selected data from the incoming data of Swordfish. To return to a state where Swordfish
counts all particles within the selected parameters, select Clear Background Count.

6 Saving Data and Images

Swordfish software can record data in formats for processing afterward. The raw particle data is saved
as NetCDF-4 files. See http://www.unidata.ucar.edu/software/netcdf/ for details. NetCDF-4
files can be read out in many third party applications including MATLAB (http://www.mathworks.com/
help/matlab/ref/netcdf.html) and LabView (http://zone.ni.com/devzone/cda/epd/p/id/
5436).

Choose the directory to save the data by selecting the project file, and assign a new prefix to the project
data if necessary. If a previous project file is selected, data will be appended to the selected file.

Figure 16: Appending particle data to the existing file

The particle size or volume distribution histogram and analysis data can be saved as MS Excel file or CSV
text file. You can either export all analyzed data, or a particular row from the data summary table. To export
all data, select File/Export All Histograms... Note that MS Excel has a limitation of maximum 255
sheets in one workbook, therefore, only maximum of 255 rows can be exported.

You can also export data associated with a particular row. Select the row in the data summary table, and
then select File/Export Current Histogram...

The Time plot and Cross plot data can be saved to MS Excel file or CSV text file via export.

7 Troubleshooting

The most common issues, with Troubleshooting solutions listed below.
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Issue Solution
Camera not connecting in Swordfish Check that the cables are

properly attached, and power is
on

Holograms are over/underexposed Adjust Pulse duration and verify
the histogram distribution

(Subsection 5.2.3).
For moving objects, keep
exposure time as short as

possible because long exposure
times will result in blurry

images.
Swordfish identifying and counting too many particles Increase Threshold.

Adjust particle size
HASP key is not detected Ensure the HASP key is

plugged in.
Try a different USB port.

Download the HASP driver from
www.4-deep.com under

Products -> Software
Downloads

Table 1: Common troubleshooting problems and solutions

8 Appendix

8.1 Hot Key Guide

Some commands of Swordfish have hot keys for quick access.

Hot Key Command
Ctrl+O Open existing or create new project file
Ctrl+E Export all histograms
Ctrl+T Export time plot
Ctrl+Q Quit Swordfish

F5 Start counting
Shift+F5 Stop counting
Up arrow Moves the counting parameter selected up by integer values

Down arrow Moves the counting parameter selected down by integer values
Left arrow Moves the threshold down when selected
Right arrow Moves the threshold up when selected

F1 Opens User Guide

8.2 Remote Control

Certain features of the Swordfish software can be controlled remotely, using the special Internet-based pro-
tocol. The remote control allows you to change Swordfish parameters from the same or different computer
anywhere on the Internet. The remote control of the software operation can be performed using the supplied
“Camera Remote Control” utility, or implemented in the 3d party software.
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To implement the remote control in you software, you need to be able to connect, read, and write data
from/to a TCP socket. The remote control is done by sending and receiving ASCII text strings through a
specific TCP port. By default, all communication is happening on TCP port 1975. When Swordfish starts, it
launches TCP/IP server and waits for the incoming text commands. Note that you need to use the correct
IP address to connect to the TCP/IP server. If your computer has multiple network interfaces, try them all
if first connection attempt fails. If you try to connect from the external network, make sure that port 1975 is
forwarded by NAT to the machine that runs Swordfish on the internal network. Make sure port 1975 is not
blocked by your firewall.

All remote commands have the same structure:

COMMAND_NAME Value\n

Where COMMAND_NAME is the name of the command to be sent/received. Value (optional) – is the value
to be sent together with the command. Value is separated from the command name by a space character.
Each command-value string is terminated by a new line (“\n”) character.

After Swordfish software processes the incoming command, it attempts to change the respective software
feature or option (for example camera recording state, or exposure value). For every valid received com-
mand, Swordfish will send a reply. Reply has the same command name as an incoming command, with
”ACK_” prepended to the command name.

For example:

FRAME_RATE 12\n

requests Swordfish to set camera frame rate to 12 frames per second. When frame rate is successfully set,
Swordfish replies with

ACK_FRAME_RATE 12\n

Do not assume that every command you send to Swordfish will be correctly processed. Wait for a respective
ACK_ reply and take the value from the reply as a new valid value. If the value or option cannot be set,
Swordfish will reply with the old valid value. For example, if we attempt to set camera burst interval to the
invalid, negative value:

BURST_INTERVAL -15\n

Swordfish will not update the burst interval, and will reply with the current, valid interval:

ACK_BURST_INTERVAL 60\n

Below is the list of remote commands with short descriptions:

ACTIVATE\n

No values. Activates the camera.

DEACTIVATE\n

No values. Deactivates the camera, stops acquisition or recording.

SYNC\n

No values. Requests Swordfish to send current camera parameters (image directory, frame rate, burst
interval, etc). All parameters will be sent as ACK_ replies. At the end of all the camera replies, ACK_SYNC
reply will be sent.

VIEW\n

No values. Activates camera view mode. Replies with the timestamp when view mode has been activated.
Timestamp is in the POSIX format – number of milliseconds since midnight, Jan 1 1970, UTC.

RECORD\n

No values. Activates camera record mode. Replies with the timestamp when record mode has been acti-
vated. Timestamp is in the POSIX format – number of milliseconds since midnight, Jan 1 1970, UTC.

15
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STOP\n

No values. Stops the camera view/record mode. Replies with the timestamp when stop has been activated.
Timestamp is in the POSIX format – number of milliseconds since midnight, Jan 1 1970, UTC.

IMAGE_DIRECTORY Val\n

Sets the current image directory for storing images recorded by the camera. Value is an absolute path to
the valid directory where images will be stored.

IMAGE_PREFIX Val\n

Sets the prefix of image files. Value is a string that will be prepended to all image file names recorded by
the camera.

FRAME_RATE Val\n

Sets camera frame rate. Value is frame rate in frames per second (floating point).

BURST_NUMBER Val\n

Sets camera burst frame number. Value is a number of frames in the burst of frames recorded by the camera
(integer). If burst number is set to 1, continuous recording will be performed.

BURST_INTERVAL Val\n

Sets camera burst interval. Value is an interval in seconds between the bursts of frames recorded by the
camera (integer).

GAIN Val\n

Sets camera gain. Value is a camera gain (usually in dB, depends on the camera model) (floating point).

AUTO_GAIN Val\n

Sets camera auto gain on or off. If value=0, auto gain is off, if value=1, auto gain is on (integer).

EXPOSURE Val\n

Sets camera exposure. Value is a camera exposure (usually in µs, depends on the camera model) (floating
point).

AUTO_EXPOSURE Val\n

Sets camera auto exposure on or off. If value=0, auto exposure is off, if value=1, auto exposure is on
(integer).

ACTIVATE_PULSED Val\n

Activates or disables pulsed laser mode, parameters are 0 and 1.

STROBE Val\n

Manual control of strobe duration, parameter is strobe duration in µs.

AUTO_STROBE Val\n

Parameter 1 or 0. Turns autostrobe off or on. Autostrobe is an algorithm to automatically control strobe
(laser pulse) duration and gain based on histogram of received camera image.

SAMPLE_INTERVAL Val\n

Sample interval for data analysis (in seconds).

ANALYZE_HOLOGRAMS Val\n

Analyze a list of holograms offline. A list is either a list of absolute paths separated by a star(*), or a list
of relative file names. Relative file names are related to the directory in which current project file (.nc) is
located. Returns number of files that were not analyzed or 0 if all files have been analyzed.
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START_COUNTING Val\n

Returns 1 if counting started and 0 otherwise; starts the counting.

STOP_COUNTING Val\n

Stops the counting; returns 1 if counting stopped, and 0 otherwise.

SET_PROJECT_FILE Val\n

Sets the name of the new project file (.nc) should be the absolute file name. Returns actual project file
name. This command tries to create all directories in path if they don’t exist. If project file already exists it
will be loaded to append new data.

PARTICLE_SIZE Val\n

Sets particle size (min and max in µm) to be detected.

THRESHOLD Val\n

Sets threshold value from 0 - 255 integer.

AUTO_THRESHOLD Val\n

Sets auto threshold on or off (1 is on, 0 is off).

ROUND_OBJECTS Val\n

Sets detection of round objects on or off (1 is on, 0 is off).

Figure 17: Camera Remote Control Utility

The convenience of Camera Remote Control utility can be downloaded and used to control Swordfish from
the local or external network. The utility implements the same remote control protocol described above.
Make sure you are connecting to the correct host IP address – the address of the computer that runs
Swordfish software.
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8.3 Principle of Operation

The Swordfish software works with the submersible or benchtop microscopes, which operate on the prin-
ciples of holography to image a volume in magnification. A 405 nm laser is focused on an aperture of the
same order of magnitude as the wavelength of the light, which produces a spatially coherent light source as
a reference wave. Light which scatters from the objects within the media (water) will interfere with the ref-
erence wave to produce an interference pattern which contains spatial and phase information of the objects
within the volume. This interference pattern, the hologram, is recorded by a CCD camera, and reconstructed
mathematically to build images of the objects within the volume.

Figure 18: The basic principle of digital in-line holographic imaging

The reconstructed images can be further analyzed, saved, or assembled into the volume reconstructions
based on the application. Swordfish automatically reconstructs holograms, counts and measures particles
in the resulting image based on parameter settings, and develops statistics based on the measurements.

8.4 The Advantages of Holographic Microscopy

The images obtained from holographic microscopy can be compared to that of dark field microscopy, except
that the collection of the images requires no constraints on the media or samples. The field of view for
traditional optical microscopes using lenses is typically a few microns; with holography, a larger field of view,
up to a couple of centimeters, allows for more dynamic experimental conditions.
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Figure 19: Field of view comparison of lens based microscope (left) and holographic microscope (right)

No need to stain or physically constrain samples with holography; the large field of view gives free movement
of microscopic organisms and particles, and allows for the field deployable Submersible microscope from
4Deep, for real time, in-situ imaging.

Along with the spatial information providing the images in the reconstructions, holograms also contain the
phase information; the differences in the speed of light passing through the objects is provided by this
information, giving Quantitative Phase Imaging (QPI) capabilities to Octopus. The measurements of the
thickness of objects obtained from phase information can be very precise, as the phase information exists
well below the wavelength of the light.

Holographic microscopes from 4Deep work simultaneously as a QPI microscope and as a dark field micro-
scope, and gather information from a macroscopic field of view with each frame. With frame rates of 15 fps
or more, and frame exposures down to 1 microsecond on some models, the holographic microscopes of
4Deep offer 4D imaging capabilities like no other microscopes.
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